VTP pruning in different VTP domains

Recently, we had a bit of a puzzle over VTP pruning. We have two switches, S1 and S2. Both of them are VTP Clients in the same domain and have pruning enabled. There is no VTP server in that domain (don’t ask).

We needed to add a VLAN to S1, but since it is a VTP client, that is not going to happen. We decided to change S1 VTP domain name to something else first, then change it a Server in the new domain. This is to prevent the S1 from changing the vlans for other clients in the old VTP domain (S2).

However, changing the VTP domain resulted in HSRP of S1 and S2 breaking. After some troubleshooting, we found out that it was caused that by us pruning vlans!

Basically, when pruning is switched on, broadcasts in a vlan are not sent to a downstream switch if that switch has no client ports in that vlan. We suspect that active vlans information of a downstream switch are propagated by VTP in a domain. When we changed the VTP domain of S1, it would have appeared to S2 that S1 has no active VLANs, thereby pruning all traffic to it! 🙂

The solution? Set S1 to VTP mode transparent. Then you can make all the changes you want to it, and it will not partake in any VTP. Should have known better, I think this is in CCNA.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s